Ir para o conteúdo
ou

Software livre Brasil

 Voltar a HonoratoNunes
Tela cheia

Ordenação de vetor

13 de Setembro de 2013, 21:44 , por jose honorato ferreira nunes - | Ninguém está seguindo este artigo ainda.
Visualizado 61 vezes

algoritmo "Ordenacao"
var
notas: vetor[1..10] de Real
L : Inteiro
Aux : Real
inicio

Para L de 1 ate 10 faca
   Escreva("Informe o valor da posição ", L, " : ")
   Leia(notas[L])
FimPara

EscrevaL()
EscrevaL("Vetor Normal")
Para L de 1 ate 10 faca
   EscrevaL(notas[L])
FimPara

Aux := notas[1]
L := 2
Enquanto (L <= 10) Faca
   Se notas[L] < Aux Entao
      notas[L -1] := notas[L]
      notas[L] := Aux
      Aux := notas[1]
      L :=2
   Senao
      Aux := notas[L]
      L := L + 1
   FimSe
FimEnquanto

EscrevaL()
EscrevaL("Vetor Ordenado")
Para L de 1 ate 10 faca
   EscrevaL(notas[L])
FimPara

fimalgoritmo


Tags deste artigo: introdução à programação