Ir para o conteúdo
ou

Software livre Brasil

 Voltar a HonoratoNunes
Tela cheia

Aulas Algoritmos e Introdução à Programação - Turma 2013.1 - Sub-Rotinas

1 de Outubro de 2013, 17:03 , por jose honorato ferreira nunes - | Ninguém está seguindo este artigo ainda.
Visualizado 128 vezes

Segue matreial de :

Introdução a linguagem C

 Introdução_à_Programação_09.pdf

Funções e Procedimentos

Introdução_à_Programação_10.pdf

Atividades de Revisão:

 Introdução_à_Programação_11.pdf

 

Resposta da primeira questão:

algoritmo "funcaonotas"
var
L : Inteiro
nota1 : vetor[1..5,1..3] de real
nota2 : vetor[1..5,1..2] de caractere

funcao media (n1,n2: real): real
inicio
retorne (n1 + n2) / 2
fimfuncao

inicio
Para L de 1 ate 5 Faca
   Escreva("Informe o nome do ", L, "º aluno : ")
   Leia(nota2[L,1])
   Escreva("Informe a nota do trabalho do ", L, "º aluno : ")
   Leia(nota1[L,1])
   Escreva("Informe a nota da prova do ", L, "º aluno : ")
   Leia(nota1[L,2])
   nota1[L,3] := media(nota1[L,1],nota1[L,2])

   Se nota1[L,3] >= 7 entao
      nota2[L,2] := "Aprovado"
   Senao
      Se nota1[L,3] < 3 entao
         nota2[L,2] := "Reprovado"
      Senao
         nota2[L,2] := "P. Final"
      FimSe
   FimSe
   LimpaTela
FimPara

Escreval("|Aluno    |Trabalho |Prova |Média |Resultado |")

Para L de 1 ate 5 Faca
   Escreva("|", nota2[L,1]:9)
   Escreva("|", nota1[L,1]:9)
   Escreva("|", nota1[L,2]:6)
   Escreva("|", nota1[L,3]:6)
   Escreva("|", nota2[L,2]:10)
   Escreval("|")
FimPara
fimalgoritmo


Tags deste artigo: introdução à programação