Ir para o conteúdo
ou

Software livre Brasil

Tela cheia Sugerir um artigo
 Feed RSS

Noticias do Ruby

7 de Julho de 2009, 0:00 , por Software Livre Brasil - | Ninguém está seguindo este artigo ainda.

As notícias mais recentes do Ruby-Lang em Português.


O suporte do Ruby 2.2 acabou

20 de Junho de 2018, 0:00, por Notícias sobre Ruby - 0sem comentários ainda

Anunciamos que todo o suporte da série 2.2 do Ruby acabou.

Após o lançamento do Ruby 2.2.7 em 28 de março de 2017, o suporte da série 2.2 do Ruby estava em fase de manutenção de segurança. Agora, após um ano, essa fase acabou. Assim sendo, em 31 de março de 2018, todo o suporte da série 2.2 do Ruby acabou. Correções de bugs e de segurança das versões mais recentes do Ruby não serão exportados para a versão 2.2, e não haverão mais lançamentos de patch da versão 2.2. Nós recomendamos altamente que atualize para o Ruby 2.5 ou 2.4 o mais rápido possível.

Sobre as versões do Ruby atualmente suportadas

Série Ruby 2.5

Atualmente em fase de manunteção normal. Nós vamos exportar correções de bugs e lançar com as correções sempre que necessário. E se um problema crítico de segurança for encontrado iremos lançar uma correção urgente para resolvê-lo.

Série Ruby 2.4

Atualmente em fase de manunteção normal. Nós vamos exportar correções de bugs e lançar com as correções sempre que necessário. E se um problema crítico de segurança for encontrado iremos lançar uma correção urgente para resolvê-lo.

Série Ruby 2.3

Atualmente em fase de manunteção de segurança. Nós nunca exportaremos quaisquer correções de bugs para a versão 2.3 exceto correções de segurança. Se um problema crítico de segurança for encontrado iremos lançar uma correção urgente para resolvê-lo. Estamos planeando para acabar com o suporte das séries 2.3 do Ruby no final de março de 2019.

Escrito por antonpaisov em 20/06/2018
Traduzido por bannergames



Tags deste artigo: ruby