Ir para o conteúdo
ou

Software livre Brasil

Tela cheia Sugerir um artigo
 Feed RSS

Noticias do Ruby

7 de Julho de 2009, 0:00 , por Software Livre Brasil - | Ninguém está seguindo este artigo ainda.

As notícias mais recentes do Ruby-Lang em Português.


Planos de suporte para Ruby 2.0.0 e Ruby 2.1

24 de Fevereiro de 2016, 9:00, por Notícias sobre Ruby - 0sem comentários ainda

Anunciamos os futuros planos de suporte para Ruby 2.0.0 e Ruby 2.1.

Sobre Ruby 2.0.0

Como anunciado anteriormente, todo o suporte para Ruby 2.0.0 se encerra hoje. Bugs e correções de seguranças de versões mais recentes de Ruby não serão mais portadas à versão 2.0.0 e nenhum patch release da versão 2.0.0 será lançado.

Recomendamos fortemente que você faça o upgrade para Ruby 2.3 ou 2.2 o mais rápido possível.

Por favor entre em contato conosco através da lista de email ruby-core caso queira continuar mantendo um branch da versão 2.0.0 com motivos pelos quais você não pode fazer o upgrade.

Ruby 2.1

Estamos planejando em lançar uma versão de Ruby 2.1.9 até o final de março. Isso significa que após o lançamento da versão 2.1.9 nós não iremos mais portar nenhuma correção de bugs para a versão 2.1, com exceção das correções de segurança.

Nós recomendamos que você comece a planejar o upgrade para Ruby 2.3 ou 2.2.

A propósito, nós estamos também planejando em lançar a versão 2.1.10 logo após a release 2.1.9. Isso não é uma correção de bugs e nem de segurança. Nós nunca tivemos antes uma versão de Ruby com dois dígitos. Portanto, nós consideramos que é importante testar essa versão sem nenhuma correção crítica de segurança.

Ruby 2.1.10 não irá incluir nenhuma mudança da 2.1.9 com exceção do número da versão. Você não deve usá-la em produção, mas sim testá-la antes do lançamento da 2.1.11 que irá provavelmente incluir correções de segurança.

Escrito por usa em 24/02/2016
Traduzido por fpgentil



Tags deste artigo: ruby